HTML: come inserire i pulsanti facebook e google plus

Vorrei inserire i bottoni facebook "mi piace" e google plus nelle pagine web del mio primo sito che sto creando con dreamweaver.
Sono andato al seguente link per facebook: http://developers.facebook.com/docs/ref ... gins/like/
ed ho seguito le istruzioni copiando i codici indicati, provando sia la versione xfbml, sia la versione iframe. Una volta copiati i codici, quando provo a visualizzare la pagina nella modalità dal vivo, o provo ad effettuare l'anteprima nel web browser, non compare nulla.
Ho provato anche con l'apposito widget disponibile in widget browser, con gli stessi risultati.
Analoghi problemi li ho con il pulsante di google plus. Ho eseguito le istruzioni disponibili sul link http://www.google.com/intl/it/webmaster ... index.html, ed ho copiato i codici indicati, con gli stessi risultati del pulsante di facebook. Dove sbaglio??
Mi potete aiutare?
Grazie. Ciao. Fabio

 ita4012, N.D.

Nel frattempo sei collegato ai rispettivi social col tuo account? In alcuni casi se non hai il profilo attivo è possibile che ti escano scritte del tipo "Accedi per vedere questo contenuto"

 Gian Paolo, N.D.

no, non sono collegato. riprovo l'operazione rimanendo collegato. e poi ti faccio sapere il risultato.
grazie. ciao. fabio

 ita4012, N.D.

Dopo aver finito tutte le pagine del sito, sono ritornato a questo problema, che avevo lasciato in sospeso. Ho inserito i codici ottenuti dalle pagine linkate nel mio precedente post, rimanendo collegato ai rispettivi social col mio account, come suggeritomi. I risultati sono i medesimi. I pulsanti non si vedono, e non compare alcun messaggio del tipo "Accedi per vedere questo contenuto".
Ho provato anche a copiare i codici proposti dal sito https://www.addthis.com/get/sharing, che, peraltro, propone soluzioni graficamente molto interessanti, e la possibilità di inserire più social buttons in poco spazio. Purtroppo, anche questo tentativo porta ai medesimi risultati.
Non vorrei dover rinunciare ad inserire questi pulsanti. Chiedo, quindi, disperatamente aiuto, e, se possibile, l'intervento di un'anima pia che mi guidi passo passo. Grazie. Fabio

 ita4012, N.D.

Dunque, ho provato questa soluzione, che funziona: http://plugins.jquery.com/social-likes/ In questo caso, cliccando su download (a sx nella pagina), si scaricano tre files: uno con estensione .html e due con estensione .js. Con questa soluzione, i file che contengono lo script java a cui rimanda il codice dell'html sono disponibili nella cartella in locale (o sul server del sito) dov'è caricata la pagina web che contiene i social buttons, e non sono quindi disponibili in remoto (server di google, facebook, ecc.), come mi pare di capire che avvenga con i codici proposti nelle soluzioni a cui facevo riferimento nei precedenti posts. A questo punto, mi sembra di capire che sia quindi un problema di corretto caricamento dei file .js necessari per far funzionare il codice html inerente i social links. Fatemi sapere cosa ne pensate, perchè mi piacerebbe capire perchè le altre soluzioni dei precedenti post non funzionano per poter scegliere quella che graficamente mi piace di più. Infine, mi chiedo se c'è qualche rischio nel caricamento dei file .js scaricati dal link sopra indicato? Grazie. Ciao. Fabio

 ita4012, N.D.

Aggiornamento: sono riuscito anche ad inserire il pulsante di base di addthis (è il 4 disponibile nella sezione "get code", sotto "Select Style"), oppure è quello ottenibile con "default code" (http://support.addthis.com/customer/por ... fault-code). Gli altri, no.
Per inserire le altre soluzioni personalizzate, ho visto anche che viene indicato di cambiare l'apetura dell'html tag (http://support.addthis.com/customer/por ... d-services). Ho provato anche ad attuare questo suggerimento, visto che le pagine del mio sito sono in xhtml 1.0 transitional, ma non ho ottenuto di visualizzare i pulsanti. Preciso che tutti i tentativi sono stati fatti sulle pagine del sito caricate in locale e non sul server. Ma se fossse questo il problema, perchè alcune soluzioni funzionano ed altre no? Ciao. Fabio

 ita4012, N.D.

Prova sul server, non ti costa niente usare una pagina di test, ad es. nascosta al pubblico che caricherai direttamente sapendo il nome del file nella barra degli indirizzi. Ad es. http://www.nomesito.it/prova.html

 Pablito, N.D.

Ho provato sul server, e funziona tutto.... grazie!
Ma perchè nelle istruzioni per i share buttons, non lo dicono subito. I profani, come me, eviterebbero di perdere tanto tempo....
Ciao. Fabio

 ita4012, N.D.
001design.it ® è un marchio registrato.
© 2004-2017 Molfese Paolo - P.Iva: 03430820617 - All rights reserved | Tutti i diritti sono riservati.