Director: visibilità ed effetto blend.

Salve a tutti,
dovrei associare ad uno Sprite la seguente azione:

1) al passaggio sopra mi si vede lo sprite 3
2) al clic va al marker pippo...

perché se io scrivo:

on mouseUp me
go to "pippo"
end

on mouseEnter me
sprite(3).visible=true
end

on mouseLeave me
sprite(3).visible=false
end

mi fa tutto però alla partenza lo sprite 3 si vede e mi si nasconde solo se ci passo la prima volta?

Qualcuno sa rispondermi?

 monigna, N.D.

Come usare lÂ’effetto blend per rendere trasparente uno sprite.

Ciao Monigna,
benvenuto/a e grazie per aver scelto 001design.it.

Riguardo al tuo quesito, succede questo perché quando lo Sprite è invisibile è come se non esistesse più.
Puoi risolvere puoi usare un “cast member change” con un cast member vuoto, oppure impostare la trasparenza dello sprite a 0, quindi impostare l’effetto blend:

on mouseUp me
go to "001design.it"
end

on mouseWithin me
sprite(3).blend=100
end

on mouseLeave me
sprite(3).blend=0
end

 Pablito, N.D.

Ti ringrazio per la dritta e per il ben arrivata, ma il tuo script stavolta non mi ha risolto il problema...
Inserendo blend al posto di visible non mi è cambiato il problema...
Cioè l’effetto che lo sprite si vede quando ci passo sopra funziona ma lo visualizza anche appena apro il file...

Dovrei creare un effetto tipo quello che si trova su questo sito: http://mv.vatican.va/2_IT/pages/CSN/CSN_Main.html

Quando passo sopra ad una delle scritte a dx (il mio ipotetico bottone sul quale inserisco lo script) mi visualizza un rettangolo (il mio sprite visible/invisible).
Allora l’effetto lo fa anche a me, quello che non va è che appena accedo alla pagina me lo visualizza da subito...
Poi va bhè se passo sulla scritta una volta scompare e poi funziona perfettamente... Il problema è l’inizio.

 monigna, N.D.

Se ho capito bene, devi solo realizzare un Movie Script (script del filmato) col seguente codice:

on startMovie
sprite(3).blend=0
end

In questo modo all’inizio del caricamento del Movie lo sprite sarà nascosto.
Per le nozioni base su Director puoi vedere al seguente link:
http://www.001design.it/forum_italiano/forums.php?id=31

 Pablito, N.D.

grazie lo stesso

Guarda, ti ringrazio sul serio tanto, anche se alla fine il problema non sono riuscita a risolverlo.
Non era quello lo script che mi serviva... proverò a sbatterci la testa ancora un po' da me.

Grazie

 monigna, N.D.

Figurati, però guarda che il Movie Script che ti ho pubblicato è giusto e ti risolve il problema.
Non confondere gli script associati al filmato con quelli associati agli sprite o al canale degli script dello Score.
Selezionando lÂ’elemento script nel Cast di Director potrai subito modificare, usando il Property Inspector, il tipo di script, ed impostare conseguentemente Movie Script.
In altre parole, gli script che devi usare sono due: uno è associato allo Sprite e l’altro è associato al Filmato.
Io ho provato e funziona perfettamente.

 Pablito, N.D.
001design.it ® è un marchio registrato.
© 2004-2017 Molfese Paolo - P.Iva: 03430820617 - All rights reserved | Tutti i diritti sono riservati.