audio caricato con attachSound che non si sente in flash est

Ciao a tutti,
ho un problema grosso e sono disperata, perché temo che la soluzione sia quella che mi piace meno...il problema è: ho diversi flash che al loro interno hanno ho una serie audio concatenati in libreria e gestiti con l'attachSound (ogni flash ha audio concatenati, se lancio il flash gli audio funzionano e si sentono, il problema nasce quando questi flash vengono caricati all'interno di un'altro flash nei flash figlio (es: 0001.swf):
var my_sound:Sound = new Sound();
my_sound.attachSound("audio0");
my_sound.onSoundComplete = audioFine;
my_sound.start(); e nel flash padre:
swf_mc.loadMovie("content/0001.swf"); var spk:Sound = new Sound(); spk.attachSound("swf_mc.audio0"); ma non funziona... qualche suggerimento in merito?
non posso caricare gli audio nella libreria del flash contenitore perché si crea dei concatenamenti con lo stesso nome
grazie mille

 simonahir, N.D.

Ciao, provabilemnte non funziona per un semplice motivo di percorsi
ad esempio nel swf figlio dovresti aggiungere _root.swf_mc.my_sound.attachSound("audio0");
ecc... per evitare tutte queste modifiche, tentativi e rotture di scatole potresti usare un comando che semplifica tutto ad esempio _lockroot cerca nella guida. In pratica blocca la radice del filmato caricato cosi evitando di cambiare tutti i percorsi nel file swf figlio. Spero di esserti stato d'aiuto. Buona fortuna ciao! ______________________________________________________________________
Ps. un caro saluto a Pablito è da molto che non lo vedo chissà se è ancora vivo ih ih ih

 max_400, N.D.

ciao max,
grazie mille della tua risposta, ma ho risolto semplicemente così:
my_sound.attachSound(this);
facendo così funziona perfettamente
grazie ancora

 simonahir, N.D.
001design.it ® è un marchio registrato.
© 2004-2017 Molfese Paolo - P.Iva: 03430820617 - All rights reserved | Tutti i diritti sono riservati.